Malware

SpeakUp – A New Undetected Backdoor Exploiting Six Linux Distributions With Known Vulnerabilities

A new trojan dubbed SpeakUp exploiting six different Linux distributions with know vulnerabilities. The campaign primarily targeting East Asia and Latin America, including AWS, hosted machines.

Security researchers from checkpoint detected the campaign that implants the backdoor and evades the detection from all security vendors.

SpeakUp

The trojan dubbed SpeakUp propagates with the infected subnet and exploiting the remote code execution vulnerabilities in Linux servers and also having the ability to install Mac devices.

Server Infection – SpeakUp

Attackers use the vulnerability in ThinkPHP for deploying a PHP shell in the server and then to execute the Perl backdoor, the infection is a three-step process.

The infection vector starts with exploiting ThinkPHP vulnerability (CVE-2018-20062) to upload the PHP shell.

Then in the next step a ibus payload injected to the server with the standard HTTP request and the payload stores in tmp directory.

The additional HTTP request sent to the server to execute the payload which executes the perl script and after two seconds the payload gets deleted.

SpeakUp

Researchers analyzed the sample with VirusTotal on January 9, 2019, and none of the AntiVirus scanners detected it.

C&C Server Communication

The SpeakUp communication starts with POST request which sends a victim ID and other information. C&C communication carried out through compromised website speakupomaha[.]com.

Following are the main functions of SpeakUp

newtask”- Execute arbitrary code on the local machine, download and execute a file from any remote server, kill or uninstall the program and sends updated fingerprint data.

notask”- Sleep for 3 seconds and ask for additional command.

“newerconfig”- Update the downloaded miner configuration file.

Vulnerabilities Exploited

  • CVE-2012-0874: JBoss Enterprise Application Platform Multiple Security Bypass Vulnerabilities
  • CVE-2010-1871: JBoss Seam Framework remote code execution
  • JBoss AS 3/4/5/6: Remote Command Execution (exploit)
  • CVE-2017-10271: Oracle WebLogic wls-wsat Component Deserialization RCE
  • CVE-2018-2894: Vulnerability in the Oracle WebLogic Server component of Oracle Fusion Middleware.
  • Hadoop YARN ResourceManager – Command Execution (exploit)
  • CVE-2016-3088: Apache ActiveMQ Fileserver File Upload Remote Code Execution Vulnerability.

“SpeakUp`s obfuscated payloads and propagation technique is beyond any doubt the work of a bigger threat in the making. It is hard to imagine anyone would build such a compound array of payloads just to deploy few miners,” researchers concluded.

You can follow us on LinkedinTwitterFacebook for daily Cybersecurity updates also you can take the Best Cybersecurity courses online to keep your self-updated.

Comment here